Publify

Making blogging easy

Moving to a new server... and to Ruby 1.9.2

If you can read this… I love starting a blog post with that sentence, it always teases something great, exciting, or just new. So, if you can read this, then, we’ve successfully moved to our new ass kicking server: Quad Core Xeon, 16GB RAM, 2*2TB hard drive on a Gigabit port with as much trafic as the machine can handle.

But that’s not the point.

This blog is running on a yet experimental but apparently working Ruby 1.9.2 compliant version. If you’ve been running 6.0.4 lately, then you can also try running Typo on a Ruby 1.9.2 environment.

This does not work out of the box though. You will need an UTF-8 aware Ruby 1.9 compliant database driver, just like sam-mysql-ruby. To do so, just edit Typo Gemfile and replace the gem 'mysql' line by gem 'sam-mysql-ruby'. If you’re using a custom theme, you’ll probably have to fix your theme encoding too.

As I’ve said, this is very experimental. However, if you’re willing to test this, we’ll be glad to hear your feedback. Just one thing though: don’t complain because you’re using a database driver that’s not UTF-8 compliant: we can’t do anything about it.

Published on 06/03/2011 at 17h43 by Frédéric de Villamil, tags , ,

  • by Frédéric de Villamil 08/03/2011 at 20h39

    Yeah, indeed, seems like I’ve been doing a little bit too much lately.

    Consider it as fixed now.


  • by Przemek 07/03/2011 at 07h21

    I’m sure You meant “Ruby 1.9.2” in the post title. :)


comment Moving to a new server... and to Ruby 1.9.2

Trackbacks are disabled

Powered by Publify – Thème Frédéric de Villamil | Photo Glenn